Service Disruption
Incident Report for Sign.Plus
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 08:44 UTC
Identified
We are currently experiencing a service disruption.
Our team is working to identify the root cause and implement a solution. Our signature flow may be affected for some users.
Posted Sep 16, 2022 - 07:45 UTC
This incident affected: Applications (Web App, iOS App, Android App, Google Add-on).