Issues with login in some regions
Incident Report for Sign.Plus
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:48 UTC
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 08:44 UTC
Investigating
We are currently investigating this issue
Posted Jun 21, 2022 - 08:42 UTC
This incident affected: Applications (Web App, iOS App, Android App, Google Add-on).