Network connectivity issue in one of our datacenters
Incident Report for SIGN.PLUS
Resolved
This incident has been resolved.
Posted Mar 15, 2022 - 20:35 UTC
Investigating
We are currently investigating this issue.
Posted Mar 15, 2022 - 19:40 UTC